はじめに

AMP-HTMLを勉強して、使用し始めてふと疑問に思っていたのだけれども、AMPJSのバージョンが上がったらどうすればいいんだろうか、と。

Google Search Console に教えてもらえる

AMPエラーなどもGoogle Search Console に登録しているメールアドレス宛に送ってもらえる。管理画面でも勿論確認できる。

AMP使うような人はSearch Consoleも使用しているだろうけど、使用していない場合は開始した方がいい。なお、コンポーネントのバージョンチェック以外にも、AMPの構文エラーがある場合も教えてもらえるので、意図しないエラーが出ているときに気付きやすい

新しいリリースが出たらなるべく早く新しいコンポーネントを指定する

よほど致命的な欠陥がない限りリリース直後に前バージョンがサポート終了になることはないと思うけれども、サポート終了になった場合、警告ではなく、エラーになってしまいAMPとして認識してもらえなくなるだろうから、気付いたら早めに対処した方がいいだろう

まぁ、新しいバージョンに欠陥がないとも言えないけれども